Using FiveLinux on Ubuntu 11.10

Using FiveLinux on Ubuntu 11.10

Postby Antonio Linares » Sat Dec 03, 2011 2:24 pm

From Ubuntu 11.10 (gcc 4.6.1) the libs linking order now matters, so we have to link gtk and glade at the end of the call to gcc:

echo linking...
gcc $1.o -o$1 -L./../lib -L./../../harbour/lib `pkg-config --libs libgnomeprintui-2.2` -Wl,--start-group -lfive -lfivec -lhbcommon -lhbvm -lhbrtl -lhbrdd -lhbmacro -lhblang -lhbcpage -lhbpp -lhbcplr -lrddntx -lrddcdx -lrddfpt -lhbsix -lhbusrrdd -lhbct -lgttrm -lhbdebug -lm -lgpm -lncurses `pkg-config --libs gtk+-2.0` `pkg-config --libs libglade-2.0` -Wl,--end-group

With these changes, it is working fine! :-)
regards, saludos

Antonio Linares
www.fivetechsoft.com
User avatar
Antonio Linares
Site Admin
 
Posts: 35350
Joined: Thu Oct 06, 2005 5:47 pm
Location: Spain

Return to FiveLinux / FiveDroid (Android)

Who is online

Users browsing this forum: No registered users and 1 guest