Erro na compilação

Re: Erro na compilação

Postby Antonio Linares » Wed Dec 16, 2009 8:58 am

Jufer,

Si buscas en estos foros por esos nombres encontrarás los enlaces de descarga que Manuel Mercado suele proporcionar:

viewtopic.php?f=6&t=17206&p=89953&hilit=tsbrowse+manuel#p89389
regards, saludos

Antonio Linares
www.fivetechsoft.com
User avatar
Antonio Linares
Site Admin
 
Posts: 35254
Joined: Thu Oct 06, 2005 5:47 pm
Location: Spain

Re: Erro na compilação

Postby jufer » Wed Dec 16, 2009 1:24 pm

Caro António,

Muito obrigado pela pronta resposta mas o meu projecto, quando compila não apresenta nenhum erro, mas quando executa apresenta erros sempre que acciono uma DIALOG dá o seguinte erro:

Dscription: Cannot create Dialog Box
GenCode: 0
Operation:
Resource: INICIAL
CREATEDDLGERROR(558)
TDIALOG:ACTIVATE(290)
PSQANO(201)
CENTROCUSTOS(159)
(b)MAIN(168)
TMDIFRAME:ACTIVATE(959)
MAIN(168)

Como posso ultrapassar este erro pois comprei a versão FWH9.10 e parece que é para deitar no lixo.

Saludos, regards

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Re: Erro na compilação

Postby Antonio Linares » Wed Dec 16, 2009 1:55 pm

Jufer,

Por favor copia aqui el contenido de tu fichero RC en donde defines ese diálogo, gracias
regards, saludos

Antonio Linares
www.fivetechsoft.com
User avatar
Antonio Linares
Site Admin
 
Posts: 35254
Joined: Thu Oct 06, 2005 5:47 pm
Location: Spain

Re: Erro na compilação

Postby jufer » Wed Dec 16, 2009 2:14 pm

Caro António,

Muito obrigado pela rápida resposta.

Como faço para mandar o ficheiro RC porque não consigo mandar quase 90000 linhas.

Saludos

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Re: Erro na compilação

Postby jufer » Wed Dec 16, 2009 3:32 pm

Caro António,

Penso que estou a enviar o que vc pediu:

INICIAL DIALOG 35, 40, 124, 128
STYLE DS_MODALFRAME | WS_POPUP | WS_VISIBLE | WS_CAPTION | WS_SYSMENU | WS_THICKFRAME
CAPTION "Seja Bem Vindo! Obrigado! Parabéns!!!"
FONT 8, "MS Sans Serif"
{
EDITTEXT 11, 84, 52, 25, 10, ES_CENTER | ES_MULTILINE | WS_BORDER | WS_TABSTOP
CONTROL "Digite o", 503, "BorStatic", SS_CENTER | WS_CHILD | WS_VISIBLE | WS_GROUP, 82, 20, 28, 9
CONTROL "Email: juliofernandes_1@hotmail.com", 501, "BorStatic", SS_CENTER | SS_NOPREFIX | WS_CHILD | WS_VISIBLE | WS_GROUP, 2, 115, 121, 11
CONTROL "Bom Trabalho", 502, "BorStatic", SS_CENTER | WS_CHILD | WS_VISIBLE | WS_GROUP, 39, 5, 55, 9
ICON "GUIJO", -1, 3, 3, 13, 13
CONTROL "TBitmap", 10, "TBitmap", 0 | WS_CHILD | WS_VISIBLE, 12, 25, 56, 67
CONTROL "Ano:", IDC_CTEXT4, "BorStatic", SS_CENTER | WS_CHILD | WS_VISIBLE | WS_GROUP, 82, 38, 28, 9
PUSHBUTTON "", 1, 9, 102, 42, 10
PUSHBUTTON "", 2, 71, 102, 42, 10
}


Saludos

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Re: Erro na compilação

Postby jufer » Wed Dec 16, 2009 3:56 pm

Caro António,

O ficheiro Error.log diz o seguinte:

----------------------------- xHarbour Error Log ------------------------------

Date...............: 16/12/2009
Time...............: 15:50:17

Application name...: C:\P_FWHB\FW9.10\CONDOM.Exe
Workstation name...: COMPUTADOR
Available memory...: 403420
Current disk.......: C
Current directory..: P_FWHB\FW9.10
Free disk space....: 12057325568

Operating system...: Windows XP Professional 5.01.2600 Service Pack 3
xHarbour version...: xHarbour build 1.2.1 Intl. (SimpLex) (Rev. 6406)
xHarbour built on..: Mar 26 2009 16:08:37
C/C++ compiler.....: Borland C++ 5.5.1 (32 bit)
Multi Threading....: NO
VM Optimization....: 2

-------------------------- Environmental Information --------------------------

SET ALTERNATE......: OFF
SET ALTFILE........:
SET AUTOPEN........: ON
SET AUTORDER.......: 0
SET AUTOSHARE......: 0
SET BACKGROUNDTASKS: OFF
SET BACKGROUNDTICK.: 1000
SET BELL...........: OFF
SET BLINK..........: .F.
SET CANCEL.........: OFF
SET CENTURY........: ON
SET COLOR..........: W/N,N/W,N/N,N/N,N/W
SET CONFIRM........: ON
SET CONSOLE........: OFF
SET COUNT..........: 0
SET CURSOR.........: 1
SET DATE FORMAT....: DD/MM/YYYY
SET DBFLOCKSCHEME..: 0
SET DEBUG..........: OFF
SET DECIMALS.......: 2
SET DEFAULT........:
SET DEFEXTENSIONS..: ON
SET DELETED........: ON
SET DELIMCHARS.....: ::
SET DELIMETERS.....: OFF
SET DEVICE.........: SCREEN
SET DIRCASE........: 0
SET DIRSEPARATOR...: \
SET EOL............: 13
SET EPOCH..........: 1910
SET ERRORLOG.......: ERROR.LOG,.F.
SET ERRORLOOP......: 8
SET ESCAPE.........: ON
SET EVENTMASK......: 128
SET EXACT..........: ON
SET EXCLUSIVE......: ON
SET EXIT...........: OFF
SET EXTRA..........: OFF
SET EXTRAFILE......:
SET FILECASE.......: 0
SET FIXED..........: OFF
SET FORCEOPT.......: OFF
SET HARDCOMMIT.....: ON
SET IDLEREPEAT.....: ON
SET INSERT.........: OFF
SET INTENSITY......: ON
SET LANGUAGE.......: PT
SET MARGIN.........: 0
SET MBLOCKSIZE.....: 0
SET MCENTER........: OFF
SET MESSAGE........: 0
SET MFILEEXT.......:
SET OPTIMIZE.......: ON
SET OUTPUTSAFETY...: ON
SET PATH...........:
SET PRINTER........: OFF
SET PRINTERJOB.....:
SET PRINTFILE......: PRN
SET SCOREBOARD.....: OFF
SET SCROLLBREAK....: ON
SET SOFTSEEK.......: OFF
SET STRICTREAD.....: OFF
SET TRACE..........: ON
SET TRACEFILE......: TRACE.LOG
SET TRACESTACK.....: 2
SET TRIMFILENAME...: .F.
SET TYPEAHEAD......: 50
SET UNIQUE.........: OFF
SET VIDEOMODE......: 0
SET WRAP...........: ON

---------------------------Detailed Work Area Items----------------------------


-------------------- Internal Error Handling Information ---------------------

Subsystem Call ....: BASE
System Code .......: 1066
Default Status ....: .F.
Description .......: Erro nos parƒmetros
Operation .........: condicional
Arguments .........: [ 1] = Type: A Val: { Array of 2 Items }
Involved File .....:
Dos Error Code ....: 0

Trace Through:
----------------
TSBROWSE:SETCOLOR : 9,333 in Module: C:\FIVETECH\MMERCADO\TSBROW~1\SOURCE\CLASSES\TSBROWSE.PRG
TSBROWSE:REDEFINE : 908 in Module: C:\FIVETECH\MMERCADO\TSBROW~1\SOURCE\CLASSES\TSBROWSE.PRG
CONDOM03 : 117 in Module: C:\P_FWHB\FW9.10\PRG\CONDOM03.PRG
(b)MAIN : 121 in Module: C:\P_FWHB\FW9.10\PRG\CONDOM.PRG
TBTNBMP:CLICK : 445 in Module: .\source\classes\BTNBMP.PRG
TBTNBMP:LBUTTONUP : 631 in Module: .\source\classes\BTNBMP.PRG
TWINDOW:HANDLEEVENT : 0 in Module:
TCONTROL:HANDLEEVENT : 1,469 in Module: .\source\classes\CONTROL.PRG
TBTNBMP:HANDLEEVENT : 1,295 in Module: .\source\classes\BTNBMP.PRG
_FWH : 3,347 in Module: .\source\classes\WINDOW.PRG
WINRUN : 0 in Module:
TMDIFRAME:ACTIVATE : 966 in Module: .\source\classes\WINDOW.PRG
MAIN : 168 in Module: C:\P_FWHB\FW9.10\PRG\CONDOM.PRG


############################## Video Screen Dump ##############################

+--------------------------------------------------------------------------------+
|Error BASE/1066 Erro nos parƒmetros: condicional Arguments: ( [ 1] = Type: A Va|
|l: { Array of 2 Items }) (Quit) |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
+--------------------------------------------------------------------------------+

Não sei se assim dá para ajudar.

Saludos, regards

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Re: Erro na compilação

Postby jufer » Fri Dec 18, 2009 2:23 am

Estou a refazer todo o meu projecto porque não conseguia ultrapassar os erros por falta de conhecimentos.

Estou só com a function main() do MENUTEST.PRG e está a dar o seguinte erro:

Aplica‡Æo:
===========
Caminho(Path): C:\P_FWHB\FW9.10\CONDOM.Exe (32 bits)
Tamanho: 2,870,272 bytes
Hora Inicial: 0 hours 0 mins 0 secs
Ocorrencia de Erro: 12/18/09, 02:17:28
Descri‡Æo do Erro: Warning BASE/1004 Message not found: TMENU:L2007
Argumentos:

Chamada da Pilha:
=================
Chamada De: TMENU:ERROR(172)
Chamada De: TMENU:MSGNOTFOUND(205)
Chamada De: TMENU:L2007(0)
Chamada De: TMDIFRAME:DRAWITEM(1133)
Chamada De: TMDIFRAME:HANDLEEVENT(0)
Chamada De: _FWH(3347)
Chamada De: SHOWWINDOW(0)
Chamada De: TMDIFRAME:ACTIVATE(949)
Chamada De: MAIN(61)

Sistema:
======
CPU Tipo: Intel(R) Pentium(R) 4 CPU 3.00GHz 3000 Mhz
Hardware Memoria: 959 megas

Recursos Livres(Free): 90 %
GDI Recursos : 90 %
Recursos Usados : 90 %

Versão do Compilador: xHarbour build 1.2.1 Intl. (SimpLex) (Rev. 6406)
VersÆo do Windows: 5.1, Build 2600 Service Pack 3

Total de Aplicações Rodando no Windows: 74
1 TF_FloatingLangBar_WndTitle
2 CiceroUIWndFrame
3 SysFader
4 M
5 Default IME
6 Monitor de estado
7 PicturePopup
8 PtEidTrayApplet
9 S/PDIF IN/OUT Settings
10 Set Device Type
11 Mixer ToolBox
12 Definições do conector
13 Logitech_HiddenMessageWnd_E1000FE7-BFF5-4746-9792-218C4CE4851D
14 QuickCam
15 Ejemplo de Menus
16 VERCE v5.3, C:\PastaVCR\CON_FW910.VRC
17 EditPlus - [C:\P_FWHB\FW9.10\Prg\MENUTEST.PRG]
18 Error.Log - Bloco de notas
19 FW9.10
20 Acrobat IEHelper
21 Caixa de entrada - IncrediMail Xe
22 www.FiveTechSoft.com • View topic - Erro na compilação - Mozilla Firefox
23 Programas
24 IncMail Main Window
25 DDE Server Window
26 NetscapeDispatchWnd
27 n
28 TISL_Places_Extension_Support_Window
29 Resource Workshop
30 WOWExec
31 MCI command handling window
32 SerLa
33 Logitech Desktop Messenger Agent
34 Nokia PC Suite
35 PCSuite
36 ControlCenter3
37 RTCMediaMessageWindow
38 CUccPlatform
39 CRTCMediaController
40 VCL ImplGetDefaultWindow
41 WinAMRestoreWnd
42 270
43 IncrediMail Spooler Window
44 LogiTray
45 ImApp Main Window
46 HelperMsgListenerWnd
47 brmfcmon
48 NokiaMServer
49 medusa_callbackpostmessage_579D20BC-1CFA-46b9-8A42-9D244829ABB5
50 pteidtrayapplet_QtSingleApplicationWindow
51 ScanSoft PaperPort Print Driver
52 DTS Connect
53 Dolby Home Threater
54 Advance Setting
55 TOOLBOX
56 Load EQ Preset
57 DeleteEQ
58 Save EQ
59 Realtek HD Audio Manager
60 BackMain_Form
61 Gestor de audio de alta definicao Realtek
62 CCALERT
63 ccApp
64 Connections Tray
65 Voltímetro
66 LVComSXWnd
67 MS_WebcheckMonitor
68 Network Activity
69 Log Viewer
70 ATI video bios poller client
71 SS
72 GDI+ Window
73 Topic reply notification - "Erro na compilação"
74 Program Manager

Vari veis em uso:
=================
Procedimento Tipo Valor
==========================
TMENU:ERROR
Param 1: C "Message not found"
Param 2: C "TMENU"
Param 3: C "L2007"
Param 4: N 1004
Local 1: U
Local 2: O Classe: TMENU
Local 3: N 13
TMENU:MSGNOTFOUND
Param 1: C "L2007"
Local 1: O Classe: TMENU
TMENU:L2007
TMDIFRAME:DRAWITEM
Param 1: N 0
Param 2: N 1242264
Local 1: O Classe: TMDIFRAME
Local 2: O Classe: TMENUITEM
Local 3: U
TMDIFRAME:HANDLEEVENT
Param 1: N 43
Param 2: N 0
Param 3: N 1242264
_FWH
Param 1: N 1242264
Param 2: N 43
Param 3: N 0
Param 4: N 1242264
Param 5: N 1
Local 1: O Classe: TMDIFRAME
SHOWWINDOW
Param 1: N 4523382
Param 2: N 1
TMDIFRAME:ACTIVATE
Param 1: C "NORMAL"
Param 2: U
Param 3: U
Param 4: U
Param 5: U
Param 6: U
Param 7: U
Param 8: U
Param 9: U
Param 10: U
Param 11: U
Param 12: U
Param 13: U
Param 14: U
Param 15: U
Param 16: U
Param 17: U
Param 18: U
Param 19: U
Local 1: O Classe: TMDIFRAME
Local 2: U
Local 3: U
MAIN
Local 1: U
Local 2: U
Local 3: U
Local 4: U
Local 5: U
Local 6: U
Local 7: U
Local 8: N 15923448
Local 9: N 7976630
Local 10: N 12615808
Local 11: N 12615808
Local 12: N 0
Local 13: N 0
Local 14: N 16777215
Local 15: N 0

RDDs Usados:
============
DBF
DBFFPT
DBFNTX
DBFBLOB

DataBases em Uso:
=================

Classes em Uso:
===============
1 ERROR
2 HASHENTRY
3 HBCLASS
4 HBOBJECT
5 TWINDOW
6 TMDIFRAME
7 TMENU
8 TMENUITEM
9 TBRUSH
10 TMDICLIENT
11 TFONT
12 TREG32

Analise da Memoria
===============
192 Variaveis Estaticas:

Consumo de Memoria Dinamica:
Memoria Atual.: 0 Bytes
Memoria Maxima: 0 Bytes

Alguém me pode ajudar??

Cumprimentos

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Re: Erro na compilação

Postby Antonio Linares » Fri Dec 18, 2009 6:54 am

Jufer,

Estas usando la Clase TMenu estandard de FWH ?

Con la clase TMenu de FWH te funcionará bien :-)
regards, saludos

Antonio Linares
www.fivetechsoft.com
User avatar
Antonio Linares
Site Admin
 
Posts: 35254
Joined: Thu Oct 06, 2005 5:47 pm
Location: Spain

Re: Erro na compilação

Postby jufer » Fri Dec 18, 2009 8:25 am

Caro António,

Muito obriado por me teres respondido. Como faço para incluir a class TMENU no meu projecto?
Basta in cluir no meu projecto a linha #Include "MENU.CH". Já fiz isso e continua o mesmo erro.

Podes ajudar-me, por favor??

Saludos, regards

Jufer
jufer
 
Posts: 50
Joined: Wed Nov 16, 2005 7:10 pm
Location: Portugal

Previous

Return to All products support

Who is online

Users browsing this forum: No registered users and 1 guest