FW_OpenAdoConnection problem with 2 connections

FW_OpenAdoConnection problem with 2 connections

Postby Maurizio » Thu Feb 01, 2018 5:38 pm

Hello
I have 2 connections on 2 different server in the same time .

Code: Select all  Expand view
#include 'fivewin.ch'

//-------------------------------------------------------------------------------------------
Function Main()
Local oRs ,oCn

 // here I open a connection on the  server  1
 oCn  := FW_OpenAdoConnection( { "MYSQL", "xxx.xxx.xxx.xxx", "dbname_1", "user", "pw" }, .t. )

 Test("first call")

 oRs := FW_OpenRecordSet(oCn, 'table')
 oRs:Close()

 
 Test("second call")

oCn:Close()



Return nil
Function Test(cTxt)

Local oCn2

  // here I open a connection on the  server  2
  oCn2:= FW_OpenAdoConnection( { "MYSQL", "yyy.yyy.yyy.yyy","dbname_2", "user", "pw" }, .t. )
 
  // The fist call is correct , I note in the browse : Current Catalog is  dbname_2
 
  // The second call is wrong , I note in the browse : Current Catalog is dbname_1 of the Server 1
    xBrowse(oCn2,'Server 2 :' + ctxt )

oCn2:Close()

REturn nil


Regards
Maurizio
User avatar
Maurizio
 
Posts: 596
Joined: Mon Oct 10, 2005 1:29 pm

Re: FW_OpenAdoConnection problem with 2 connections

Postby nageswaragunupudi » Thu Feb 01, 2018 7:08 pm

We are looking into this.
Regards

G. N. Rao.
Hyderabad, India
User avatar
nageswaragunupudi
 
Posts: 5563
Joined: Sun Nov 19, 2006 5:22 am
Location: India

Re: FW_OpenAdoConnection problem with 2 connections

Postby nageswaragunupudi » Tue Feb 13, 2018 4:13 pm

Fixed in FWH 1801.
Many thanks for pointing out.
Regards

G. N. Rao.
Hyderabad, India
User avatar
nageswaragunupudi
 
Posts: 5563
Joined: Sun Nov 19, 2006 5:22 am
Location: India

Re: FW_OpenAdoConnection problem with 2 connections

Postby Maurizio » Wed Feb 14, 2018 2:50 pm

User avatar
Maurizio
 
Posts: 596
Joined: Mon Oct 10, 2005 1:29 pm


Return to FiveWin for Harbour/xHarbour

Who is online

Users browsing this forum: Google [Bot] and 9 guests