Problemas para enviar mails con TSMTP()

Problemas para enviar mails con TSMTP()

Postby FiveWiDi » Wed Dec 13, 2017 10:01 pm

Hola a todos,

A ver, hasta hace poco podía enviar mails (a veces fallaban) desde una aplicación de escritorio hecha con FWH, usando TSMTP.PRG de FWH.

Hoy en día siempre tengo este mensaje de error:

MsgStop( "The IP address " + ::cIPServer + " could not be resolved" + CRLF + ;
"Make sure you're connected to the internet and" + CRLF + ;
"check the firewall settings if applicable", MSG_CAPTION )

esto ocurre cuando:

Elseif ::cIPServer == "0.0.0.0" .or. Empty( GetHostByAddress( ::cIPServer ) )
(*) Ver nota al final.

Es decir, si no se podía averiguar el nombre del servidor de correo a partir de la IP, entraba en error.
De "smtp.rebuts.cat" puedo conocer su IP "46.16.61.50", pero de la IP no puedo conocer "smtp.rebuts.cat".

Consultado el servico de hosting que tengo contratado, me responden:

"Su servicio de correo es de tipo compartido, por lo que su servidor de envío (smtp.rebuts.cat)
apunta a un clúster que le asigna un maquina diferente por cada mensaje que solicita tramitar
(por ello recibe mensajes de error desde fnsib-smtp06.srv.cat o fnsib-smtp07.srv.cat).
Dicha conexión debe realizarse sin forzar la utilización de SSL. Además, no se ha realizado
ningún cambio a nivel de infraestructura que afecte a esta funcionalidad del servicio"

Ellos no saben que modifiqué la rutina para saltarme el mensaje de error y forzar el intento de conexión, de ahí que hablen de "fnsib-smtp06.srv.cat o fnsib-smtp07.srv.cat".

Aquí mis preguntas:

¿Porqué en necesario que la rutina de TSMTP() deba conocer el nombre del servidor a partir de la IP?
¿Porqué "::oSocket:Connect( ::cIPServer )" debe estar fallando, si la IP es correcta?
¿De que manera se está conectando "::oSocket:Connect()" para que sólo con la IP no funcione (y se obligue a conocer el nombre del servidor de correo)?

Me atreví con ustedes porque llega Navidad y con ella algún que otro regalo.
Que sean felices.
Y si saben alguna respuesta... ;)

(*) Esto me era conocido desde hace meses o años, y opté por modificar la rutina par saltarme este condicional.
Un Saludo
Carlos G.

FiveWin 15.07 + Harbour 3.2, BCC 7 Windows 7
FiveWiDi
 
Posts: 867
Joined: Mon Oct 10, 2005 2:38 pm

Return to FiveWin para Harbour/xHarbour

Who is online

Users browsing this forum: No registered users and 5 guests